Dwolla V2 with rails server error


(Arsen Ugliar) #1

Having some problems with transfers in my rails app. Always getting a Serwer Error (message: a server error occurred) event though I think token & request_body of the transaction are good.

Also on my sandbox account in Activity tab I’m always getting: Error. An error occurred fetching your scheduled transactions.. Except that, I tried to register a new sandbox account & not getting a verification email (tried two different emails).

Here’s my request_body:

request_body = {
    :_links => {
      :destination => {
         :href => "mailto:some_email"
      },
      :source => {
        :href => "https://api-uat.dwolla.com/funding-sources/fundig_source_id"
      }
    },
    :amount => {
      :currency => "USD",
      :value => "2.00"
    }
  }

Here’s my token:

#<DwollaV2::Token client=#<DwollaV2::Client id=“gjk…” secret=“8XF…” environment=:sandbox> access_token=“cBp…” refresh_token=“dRA…” expires_in=3588 scope=“send|funding” account_id=“348…”>

And transfer request:

token.post 'transfers', request_body

Everything is done on a sandbox account.

Would be grateful for any suggestions why that SerwerError may occur and information If that could be something happening on your side.

**EDIT: mass-paymets are working fine and not returning SerwerError


(Jared Dellitt) #2

Hey @Arsen_Ugliar - it does look like there’s a problem with sending to an email in our sandbox environment. I’ll post back here with an update once we get it straightened out.


(Arsen Ugliar) #3

Thx for the response. I’ve already implemented mass payments, buy good to know anyway :slight_smile:


(Cory Anderson) #4

(Cory Anderson) #5

(Cory Anderson) #6