Issue with Transfer money


(Ashwini S) #1

Hi,

week before transfer money API was working fine but now if i trying to transfer any amount like 10,50,100…
Its giving me an error like invalid amount.
Any one can help me to fix this issue.

API: https://api-uat.dwolla.com/transfers

Params:
transfers._links.destination.href =https://api-uat.dwolla.com/funding-sources/6322c6be-c790-4a9e-8e00-00e53f47a0a5
transfers._links.source.href = https://api-uat.dwolla.com/funding-sources/6322c6be-c790-4a9e-8e00-00e53f47a0a5
transfers.amount.currency ="USD:"
transfers.amount.value=“100”

Response:

{StatusCode: 400, ReasonPhrase: ‘Bad Request’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
{
Connection: keep-alive
Access-Control-Allow-Origin: *
X-Request-Id: 39498305-573c-4c64-9ce5-2a4dba3c8e3a
CF-RAY: 28c1bb495d462ddf-BOM
Date: Thu, 31 Mar 2016 06:26:46 GMT
Set-Cookie: __cfduid=d11ec1dc3dbef80ae3976ec19cace44541459405605; expires=Fri, 31-Mar-17 06:26:45 GMT; path=/; domain=.dwolla.com; HttpOnly
Server: cloudflare-nginx
Content-Length: 205
Content-Type: application/vnd.dwolla.v1.hal+json; profile=“http://nocarrier.co.uk/profiles/vnd.error/”; charset=UTF-8
}}

Error Msg:
Invalid amount value

Thanks,
Ashwini S


(Spencer Hunter) #2

hmm, It looks like you are sending from and to the same bank account which is not allowed. Additionally, the colon after USD (":") may be throwing the request off. Try removing the colon after USD to see if the request is successful.


(Ashwini S) #3

Hi We removed : from USD and destination and source links also different but still not able to transfer money for some accounts.


(Spencer Hunter) #4

@ashwini_s, You mention “some” accounts. Were you able to get a transfer to go through successfully for some accounts? What type of funding source are you attempting to send money from? Can you show a request you are trying where the source and destination links are different? Thanks!


(Cory Anderson) #5

(Cory Anderson) #6

(Cory Anderson) #7