OAuth - Sandbox error when adding a funding source via OAuth

(Mass Venture) #1

Please see image below we are still getting the following on in the oauth flow when we were adding a funding source. Please let us know if the logs show anything different that we need to do. We emailed about another error yesterday and wondering if this is related.

(Spencer Hunter) #2

Hi @MassVenture, Can you private message me the following details?

  • Timestamp of when this error occurred
  • the email address of the Sandbox account you were using to go through the OAuth flow
  • If possible, the steps you took leading up to this error


(PJ Caraher) #3

@spencer This may be related, I too am experiencing Sandbox errors when adding a funding source with code that was previously worked.

Here is a snippet of my python code:

 dwollaURL = 'https://api-sandbox.dwolla.com'
 client = dwollav2.Client(id = consumer_key,
                            secret = consumer_secret,
                            environment = 'sandbox')

 def create_bank_account(customerId, dict) :
    customer_url = str(dwollaURL + '/customers/' + customerId)
    request_body = {}

    try :
            request_body["routingNumber"] = str(dict["routingNumber"])
            request_body["accountNumber"] = str(dict["accountNumber"])
            request_body["type"] = str(dict["type"])
            request_body["name"] = str(dict["name"])

            app_token = client.Auth.client()
            customer = app_token.post('%s/funding-sources' % customer_url, request_body)
     except dwollav2.ValidationError as apiEx:
            body = apiEx.body

When I submit the following request_body:
{‘type’: ‘checking’, ‘routingNumber’: ‘222222226’, ‘name’: ‘Test Account’, ‘accountNumber’: ‘123456789’}

I receive the following dwollav2.ValidationError:
{u’message’: u’The requested resource was not found.’, u’code’: u’NotFound’}


  • The customerId used corresponds to a customer in my sandbox.
  • This code has worked previously.