Create Funding Sources results in Not found

I am trying to create funding source on sandbox account. I am following this one
https://docs.dwolla.com/#create-a-funding-source-for-a-customer
but when I send request to create funding source, it returns
{
“code”: “NotFound”,
“message”: “The requested resource was not found.”
}
I am trying with postman request, my token is valid and post url is
https://api-sandbox.dwolla.com/customers/{customer-id}/funding-sources
Content type and Accept vals “application/vnd.dwolla.v1.hal+json”
I can create new customer using same authentication method but only issue facing while creating funding source. Can you please where is mistake.
Best Regards

Hi @Zapp_Investment_Cons

Can you please share the exact request URL and body you are sending

Hello @kmoreira,

I’m running into that same issue as well. Here’s our requests:

Create Funding Source

{
  "map$dwolla_v2_kotlin": {
    "plaidToken": "processor-sandbox-...",
    "name": "Plaid Checking"
  }
}

Create Funding Response

{
  "statusCode": 201,
  "headers": {
    "map$dwolla_v2_kotlin": {
      "connection": "keep-alive",
      "set-cookie": "...",
      "location": "https://api-sandbox.dwolla.com/funding-sources/b87e315a-8390-40ff-8193-920b10546138",
      "date": "Fri, 27 Aug 2021 17:30:01 GMT",
      "cf-ray": "...",
      "expect-ct": "...",
      "server": "...",
      "content-type": "application/vnd.dwolla.v1.hal+json",
      "x-request-id": "9d3d3b00-0e14-4bcf-aab9-d111e7e2d1da",
      "cf-cache-status": "...",
      "content-length": "..."
    }
  },
  "body": "<blank, but likely because the library doesn't deserialize this correctly>"
}

Fetch Funding Source Request
We’re hitting the aforementioned Location header

(https://api-sandbox.dwolla.com/funding-sources/b87e315a-8390-40ff-8193-920b10546138)

Fetch Funding Source Response

{
  "code": "NotFound",
  "message": "The requested resource was not found."
}

For the last few months we’ve been using this code and have had no issues, but today it seems to be having an issue. Let me know if you need anymore information!

Hello @kmoreira ira
Here is code we trying, token may expire but issue is with Not Found when token is valid, rest its actual values

$curl = curl_init();

curl_setopt_array($curl, array(
CURLOPT_URL => “https://api-sandbox.dwolla.com/customers/fe962f91-2359-472c-bfdf-2606459739c6/funding-sources”,
CURLOPT_RETURNTRANSFER => true,
CURLOPT_ENCODING => “”,
CURLOPT_MAXREDIRS => 10,
CURLOPT_TIMEOUT => 30,
CURLOPT_HTTP_VERSION => CURL_HTTP_VERSION_1_1,
CURLOPT_CUSTOMREQUEST => “POST”,
CURLOPT_POSTFIELDS => “routingNumber=222222226&accountNumber=123456789&bankAccountType=checking&name=Jane%20Doe%E2%80%99s%20Checking”,
CURLOPT_HTTPHEADER => array(
“Accept: application/vnd.dwolla.v1.hal+json”,
“Authorization: Bearer CFH6pQvJtsPhmM51DYzbC9ZHZj84JRIGq54UaOVyBfy6CFobra”,
“Cache-Control: no-cache”,
“Content-Type: application/x-www-form-urlencoded”,
“Postman-Token: c0c889f7-6ffc-409a-a12f-3c1a4d69ace3”
),
));

$response = curl_exec($curl);
$err = curl_error($curl);

curl_close($curl);

if ($err) {
echo “cURL Error #:” . $err;
} else {
echo $response;
}

Hi @Zapp_Investment_Cons , Are you still seeing this issue and would you be able to retry your request? On Friday we experienced a small issue with a subset of API consumers to where newly created funding sources weren’t accessible. This issue should have been resolved shortly after you posted. Apologies for any inconvenience and please let us know if there’s anything else we can do to assist!

Hi @spencer, I just tried it now but same issue of not found, I tried with fresh Token but no result.
I am facing this issue even before creating this ticket but before creating ticket I put 1 week to check all document to sure that may be issue in somewhere in my request, but its seems fine as per your provided documents.
Thanks

Hi @Zapp_Investment_Cons – I spot checked some of the calls coming from your application to that endpoint, and it looks like they have empty request-bodies. That seems to be what’s causing that error.

When you get a chance, would you be able to check the request body in Postman and see if it’s missing?

Hi @shreya
As you can see above code sample, there is body available
these are post fields which we are sending in request.
CURLOPT_POSTFIELDS => “routingNumber=222222226&accountNumber=123456789&bankAccountType=checking&name=Jane%20Doe%E2%80%99s%20Checking”,

It looks like your CURLOPT_POSTFIELDS value is being populated incorrectly. Can you try the following?

CURLOPT_POSTFIELDS =>'{
  "routingNumber": "222222226",
  "accountNumber": "123456789",
  "type": "checking",
  "name": "Jane Doe - Checking"
}'

Hi @shreya
Thank you for your help. I always try API first with postman and there I was setting post fields correctly even I tried with all possible ways with form-data, raw, binary and urlencoded but it wasn’t working with anyone.
Now I tried it with real code as you points that post fields are not correct, I tried with correct values with code and its worked fine.
Postman spoil my 2 weeks.
Thanks you again for your help, we have find issue and fixed with your help.
Best Regards

Hi @Zapp_Investment_Cons - glad that helped!

Also, if you’d like to try this again with Postman, you can check the examples below to see if anything was missing -


Headers


Request-body