Forbidden error, when try to auth with node dwolla-v2

(Timestopper) #1

Hello, I’ve tried exactly with the same code and my activated sandbox account:

And I am getting in response:’,
status: 403,
statusText: ‘Forbidden’,

I’ve figured out it only when debugged dwolla-v2 library sources. Otherwise it just displays in the application:

error: create customer error SyntaxError: Unexpected token < in JSON at position 0
at Object.parse (native)
at C:\dev\codesource\chat1\himarley-main\master\marley-ach\node_modules\node-fetch\lib\body.js:48:15

My application id: T7bhqI3DzFiQIhlqQPrrKA5s1Z2b4cF73N83naTkglIEIFJAef

This code fires the same error:

.then(function(appToken) {
return appToken.get(‘webhook-subscriptions’);
.then(function(res) {

So it’s the same error for the appToken.get(’/’) and appToken.get(‘webhook-subscriptions’)

Thanks in advance!

(Timestopper) #2

If I try a direct request with curl or postman it asks me to enter a captcha in response html code:

curl -H “Content-Type: application/json” -X POST -d ‘{“client_id”:“…”,“client_secret”:“…”,“grant_type”:“client_credentials”}’

(Timestopper) #3

It was exactly this issue and now it works great!