Transfer request error

hi there, I’m trying to post this request from a account balance funding source to a customer funding source:
{“_links”=>{“source”=>{“href”=>“”}, “destination”=>{“href”=>“”}}, “amount”=>{“currency”=>“USD”, “value”=>“12.12”}}

and it’s returning: DwollaV2::BadRequestError: {“code”=>“BadRequest”, “message”=>“The request body contains bad syntax or is incomplete.”}

I’ve previously tried processingChannel destinations, and other meta data, but they all seem to fail. is there a way to get more verbose errors?

event an exact copy from the transfer docs shows the same error, eg (with my funding sources):

transfer_request = {
  :_links => {
    :source => {
      :href => ""
    :destination => {
      :href => ""
  :amount => {
    :currency => "USD",
    :value => "225.00"

transfer = "transfers", transfer_request

this also provides the same error

Hi @Joel_Richards , I believe it’s the /balance at the end of the Funding Source URL that might be throwing the request off. Can you try removing that from the URL in the source href to see if that works?

Hi Spencer, thanks. Also I’m trying to test out RTP transfers and docs suggest I need to email support to get this enabled. I emailed support@ 12 days ago, with no ticket number or reply? is there a quicker/easier way to get this enabled?

Hi @Joel_Richards , Apologies for the delay in response. I just enabled RTP on your Sandbox account for testing. Please let me know if this feature is working now and if you have any follow up questions!