Sending Money To Customer Issues

We have never sent money (withdrawals) to customers. We have updated our code to process transfers from our Dwolla Balance to the Customers Link Bank Funding Source. When testing in Sandbox we see some strange behavior.

First, we don’t see all the transactions in the Transaction List, but when we click on “Trends” we see the correct data in the graph (Amount and # of transfers). Why don’t we see them on the Transaction List or Customer List.

Second, How do we test failing these transactions. We tried changing the Funding Source Name for the customers account to and R02 (Closed account) and then hit processed it doesn’t fail the transaction.

Third, I do have one customer that has an R01-late bank account name and that transaction is showing with Status = Processed but when clicking on the Related Transfers Box the Receiver’s balance to bank is showing as Failed. Why does the related transfer say Process but the Receiver transaction say failed? And how do we get a response so we can handle the failure?

Hi @jlansden

  1. If the transfers are from your Master Account’s Balance to Customers’ bank accounts, then they should appear in the Transactions tab. Would you be able to post one of the transactions IDs that isn’t showing up in the Dashboard? We can take a look at our end and see what the issue is.
    Essentially, the transactions tab lists all transfers related to your Master Account. If there are transfers from a Customer account to another Customer account, then those aren’t found in the main Transactions tab, and can be found under the related Customer’s list of transactions.

  2. You’re on the right track with testing transfer failures in sandbox by updating a funding-source name to a sentinel value. However, R02 is not a supported value. You can use any of the four values as explained in this guide, namely R01, R01-late, R03, R03-late.

  3. Both of the transfers should update to failed after clicking on the Process Bank Transfers button two times.
    Would you be able to share the transaction ID so I can take a look?

Issue # 1 - Here is 1 transaction that does not appear on the customer Transaction List we have a few others- https://api-sandbox.dwolla.com/transfers/1ff18ed2-f425-eb11-8129-d2ba35ae0f85

Issue #3 and here is an R01-late transaction - 0c095b11-fa25-eb11-8129-d2ba35ae0f85

Thanks for the IDs, Jennifer!

For #1, I will have our team take a look into that! If you come across any new instances of transfers not appearing in the Dashboard, do let us know!

For #2, the R01-late value is supposed to be used in the source funding-source to simulate a late return for insufficient funds from the source. In this case, the destination R01-late is being used in the destination, which will not produce the expected results. Would you be able to try updating the source bank name to the sentinel value and creating a transfer again? You should be able to get the appropriate webhooks that denote the transfer as being processed, then failed.

Let us know if you have any questions!

#1 This seems to happen to about half of our batch test the first time we run it and then the 2nd time we run it the entire batch works. So I have about 5-6 transactions that this happened to - Here is one more. - https://api-sandbox.dwolla.com/transfers/1df18ed2-f425-eb11-8129-d2ba35ae0f85

Hi @jlansden, Sorry for the troubles here, we have the engineering team investigating why those aren’t reflecting in your transactions listing. It looks to be isolated to an issue with internal Sandbox events on a specific day. Are new transactions being recorded properly?

Hi Spencer,

I just ran the same test today and it worked. I am just concerned because when we run in production we have a lot and won’t be able to check them in the dashboard.

Hi @jlansden, I definitely understand the concern and have relayed this on to our engineering team. However, the infrastructure behind how transactions work in Sandbox and Production is different. The Sandbox uses a fake service for recording transactions that are created and therefore wouldn’t result in the same behavior occurring in production.

@spencer or @shreya
For item #2, I changed our bank funding source to R01 but the withdrawals are still not failing. I think our developer is processing the money from our Dwolla balance to the Customers Funding Source. How do we fail these transactions? I tried changing the Dwolla funding source name but it gives me an error saying that is not a bank.

Hi Jennifer!

Ah you won’t be able to simulate R01 ACH return (insufficient funds) from a Balance. If the Balance were to have insufficient funds, the transfer request itself would fail and a transfer won’t be created.

If you were looking to test ACH failures on the destination bank account, then you can use either R03 or R03-late as the destination bank name.

Hope that helps!

I’m sorry but I have tried and it still doesn’t work The transfers don’t fail.

This one I named both banks R03 -Here is the # 55871133-e529-eb11-8129-d2ba35ae0f85 and the related transfer 56871133-e529-eb11-8129-d2ba35ae0f85 which is failed.

This one I tried R03-late 2b0647d0-e629-eb11-8129-d2ba35ae0f85 & Related 2c0647d0-e629-eb11-8129-d2ba35ae0f85 which is failed.

When we send money to a customer it is possible to fail on their end because they may have closed the bank account since it was originally created correct? So we want to replicate that happening.

Also I notice that withdrawals automatically go to ‘Processed’ shouldn’t they be ‘pending’ and then when I hit the ‘process transfer’ button they go to processed’?

Thanks for those IDs!

I checked, and found that both of those transfers have failed on the destination side, as expected. The first leg of the transfer (from your Master Account to the Receiver’s Dwolla Balance) process successfully. Then, the second leg of the transfer (from the Receiver’s Dwolla Balance to their Bank) failed, which caused the funds to land in the Receiving Customers Dwolla Balance. You are probably seeing a processed status in the original transfer, but a failed status on the funded-transfer (withdrawal). This is expected behavior for when the withdrawal portion of a transfer fails when the receiver is a Verified Customer with a Dwolla Balance funding-ssource. If the Receiver was an Unverified Customer type without a Dwolla Balance funding-source to hold funds, then the funds would stay in your Master Account’s Balance if an R03 (Account not found) return was received.

For this, since the first leg of the transfer is from your Master Account’s Dwolla Balance to the Receiver’s Dwolla Balance, the re-allocation of funds happens instantly, which is why you would see a processed status on that transfer immediately after creating it. It’s only for simulating bank transfer processing that the button needs to be clicked. For example, the second leg of the transfer going from the user’s Balance out to their attached Bank account.

Hope that helps make things a bit more clear! Spencer has a good post that I wound recommend checking out; it’s about Bank Transfers in Dwolla and the multiple webhooks that are sent indicating the completion of the various legs involved - Bank Transfer vs Transfer (Webhook)
If you have any questions, do let us know!