Addition of new accounts stopped working

Hello!

I am suddenly unable to make Dwolla accounts. The code I’ve written for this is longstanding and has worked until now. Here’s git blame output:

24d7567ab (Fox Piacenti        2018-03-16 12:24:54 -0500  22) def make_dwolla_account(request, user, first_name, last_name):
4233daaa7 (Fox Piacenti        2019-04-16 11:27:17 -0500  23)     if user.artist_profile.dwolla_url:
4233daaa7 (Fox Piacenti        2019-04-16 11:27:17 -0500  24)         return user.artist_profile.dwolla_url
24d7567ab (Fox Piacenti        2018-03-16 12:24:54 -0500  25)
5b1538900 (Fox Piacenti        2018-03-12 17:10:00 -0500  26)     request_body = {
24d7567ab (Fox Piacenti        2018-03-16 12:24:54 -0500  27)         'firstName': first_name,
24d7567ab (Fox Piacenti        2018-03-16 12:24:54 -0500  28)         'lastName': last_name,
5b1538900 (Fox Piacenti        2018-03-12 17:10:00 -0500  29)         'email': user.email,
24d7567ab (Fox Piacenti        2018-03-16 12:24:54 -0500  30)         'ipAddress': get_client_ip(request)[0]
5b1538900 (Fox Piacenti        2018-03-12 17:10:00 -0500  31)     }
5b1538900 (Fox Piacenti        2018-03-12 17:10:00 -0500  32)
5b1538900 (Fox Piacenti        2018-03-12 17:10:00 -0500  33)     with dwolla as api:
4233daaa7 (Fox Piacenti        2019-04-16 11:27:17 -0500  34)         user.artist_profile.dwolla_url = api.post('customers', request_body).headers['location']
4233daaa7 (Fox Piacenti        2019-04-16 11:27:17 -0500  35)         user.artist_profile.save()
4233daaa7 (Fox Piacenti        2019-04-16 11:27:17 -0500  36)     return user.artist_profile.dwolla_url

The dwolla variable here is a context manager I’ve created to generate a token for the duration of the code in the with statement. Its code is also longstanding and works for every other request to the Dwolla service. I can check transfer statuses just fine, for instance.

I’m unable to reproduce this issue on the sandbox. The error I’m receiving is:

{"code":"Forbidden","message":"The supplied credentials are not authorized for this resource."}

Hi @Fox_Piacenti – would you be able to share a request_id for one of these requests that are failing/erroring? Any other resource ID created within your application would also work! I can then take a look at our request logs, or your account settings to see if I find something odd.

Here is a UUID of a resource created by our application: fce2d8e2-6eab-42fb-a25a-6b7ed799acd3 . Thank you!

Thanks for sharing the UUID! It looks like the account settings for your Dwolla account is set to creating users of type Receive-only, as per your contract, which is why the above request for creating a Customer of type Unverified Customer is failing with the error.

Hello!

I have added "type": "receive-only", to the request data, and the error is still occurring. Could you please take another look?

Thank you!

Hi @Fox_Piacenti – I checked the latest request that failed with a 403 status code and the request-body doesn’t look like it has the field "type": "receive-only" present. Would you be able to check and send a request again with the field added? Here’s the request-id of the latest request that came in at 7/13/20 12:09:50.623 PM CT - 9ceb3cf3-e151-4ba2-8e3b-b9067279a549

Turns out I added the data to the wrong endpoint request. Fixed that, and now it works. Thanks!

1 Like

Sweet! Thanks for the update! :slight_smile: