Getting Error While Creating card-funding-sources-token

I want to create card funding source token and
I Am calling api for card-funding-sources-token
and i am getting this below error
“code” => “InvalidScope”
“message” => “Application does not have required scopes for creating token.”

Same thing works fine with funding-sources-token

Hi Ravi – Thanks for posting!

The Push-to-Debit functionality is a premium feature available in the Production environment in the Scale tier and not enabled by default in the sandbox at this time. You can find more information on the different tiers in our pricing page.

I can turn the feature on for your Sandbox account if you’d like to test with it! :slight_smile: Is your Sandbox account under the same email as your email address used here?

Yes please enable it , i need to test this in sandbox

Cool! I just flipped the switch on. You should be good to go!

Let us know if you run into questions or issues!

Can you please add me also for Cards funding source to my Sandbox account (shyamsunder.sharma@5exceptions.com) for testing.

Hi @shyamsunder.sharma – you should be good to go! :+1:

Can I also have this turned on for hi@kalepayroll.com ?

This feature should now be enabled @cairashields

1 Like

Can I have this enabled for my sandbox account adrian@juice.so ? Thanks in advance.

Hi @agarbund

I enabled this feature in your sandbox account for testing

1 Like

Thanks @kmoreira
I’m no longer receiving “Application does not have required scopes for creating token.” error, but now, when trying to call
https://api-sandbox.dwolla.com/customers/214292e1-8bbb-4269-920f-b78570795908/card-funding-sources-token
I get “The requested resource was not found.” error.

I also tried https://api-sandbox.dwolla.com/customers/214292e1-8bbb-4269-920f-b78570795908/funding-sources-token and it works fine.

Hey @agarbund

Sorry about that. There was an additional step I needed to complete on my end for the sandbox account that I missed yesterday. The error should clear now :slightly_smiling_face:

Hey @kmoreira, unfortunately still getting “The requested resource was not found.” error when trying to call POST on https://api-sandbox.dwolla.com/customers/214292e1-8bbb-4269-920f-b78570795908/card-funding-sources-token

Any idea?

Hi @agarbund, hmm, that should be working now. Can you give it one more shot and if that doesn’t work we can dig in a little further to figure out what could be going wrong with the configuration on our end?

Works now. Thank you!

1 Like

Can someone please enable this permission for my sandbox account as well? @spencer @shreya @kmoreira

@Cody_Eddings Good to go :slightly_smiling_face:

Hi @kmoreira,

Could you please enable this feature for my sandbox account as well?

Thank you!

Hi @philoniare – you should be set! :+1:

Hi,
Can anyone enable this feature in sandbox for email(cashslapp@gmail.com)