Invalid Funds Flow

Hi, a customer tried to make a payment and received the following error: "Invalid Funds Flow: this operation required the funds flow receive to be enabled. Has anyone had this problem before? Thanks

Hi @Miashare – Upon checking your account, it looks like you have the Send funds flow enabled which only allows you to create pay-outs to your Customers. Attempting to create a pay-in from a Customer into your Master account will result in the above error.

If you’d like to create pay-outs as well as pay-ins, you’d have to choose a combination of both Send and Receive funds flows.

Let us know if you have any questions!

Thanks @shreya ere do we do this? How do we turn Receive on?

We are following this guide https://developers.dwolla.com/guides/receive-money#receive-money-from-your-users

Hi @Miashare! Apologies for getting back to you late! Looks like we were able to turn that on for you!

You should now be able to both Send and Receive!

@shreya We have the same issue. How do I send my information to you and enable the funds flow?

Hi @sichaoy

Shreya’s on holiday, but I can do this for you. Can you post or dm me the email you used to open the sandbox account? I wasn’t able to find an account based on the forums email

Hi @shreya @kmoreira
Verified LLC and Plaid-bound bank card to transfer money to the customer:Invalid Funds Flow: this operation requires the funds flow ‘Facilitate’ to be enabled, What causes it?

We have test transfer in sandbox, there is no problem. The problem is in the production environment. Please see the transfer request and the error message, here both the funding source are verified.

<{“amount”:{“currency”:“USD”,“value”:“2.00”},"_links":{“destination”:{“href”:“https://api.dwolla.com/funding-sources/09571dbb-0627-4dbc-81c5-aa93b13f77d1"},“source”:{“href”:“https://api.dwolla.com/funding-sources/f3d7a988-6975-4211-bfe9-ad6687145c72”}},“correlationId”:“prod59”},[Authorization:"Bearer OL054keTadYGAEcN0AwqK89OeQui5fpfdvJbsH8b6v5wZKe4Gx”, Content-Type:“application/vnd.dwolla.v1.hal+json”, Accept:“application/vnd.dwolla.v1.hal+json”]>

<403,{“code”:“Forbidden”,“message”:“Invalid Funds Flow: this operation requires the funds flow ‘Facilitate’ to be enabled”},[Date:“Mon, 04 Jan 2021 05:22:16 GMT”, Content-Type:“application/vnd.dwolla.v1.hal+json; profile=“http://nocarrier.co.uk/profiles/vnd.error/””, Content-Length:“118”, Connection:“keep-alive”, Access-Control-Allow-Origin:"*", X-Request-Id:“b2b0db36-d5cf-432d-ac22-4c8afefedd09”, CF-Cache-Status:“DYNAMIC”, cf-request-id:“076d71aa2a0000eb0079b05000000001”, Expect-CT:“max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct””, Server:“cloudflare”, CF-RAY:“60c28556a87ceb00-LAX”]>

Hi @iream

In production, this could be caused by the standards of your contract. If your contract states that your funds flow is a send and receive only, then facilitate would not be enabled.

To find out information about what a funds flow upgrade would entail, you can email integration@dwolla.com