Sandbox funding sources limited to only one per customer

Hi,

I’m trying to test out sending Me to Me transfers using the Plaid + Dwolla integration but running into an issue where it’s only allowing one funding source per Sandbox customer. The error the API is returning is: MaxNumberOfResourcesError: {“code”=>“MaxNumberOfResources”, “message”=>“The maximum number of banks have been added.”}

This can also be confirmed by logging into the Sandbox dashboard, going to the user’s page and funding sources tab. The “+” button is greyed out and disabled.

I understand that this may be a limitation of the Sandbox environment but how are you supposed to test Me to Me transfers if you cannot add more than one funding source to a Sandbox customer?

Thanks for any help.

Hi @acomeyer – it looks like your Sandbox account may have been affected by a permissions issue we had around 11/19/2020. Would you be able to share a Customer ID (or any Dwolla resource ID) so I can take a look and enable the appropriate settings?

Thanks and apologies for the inconvenience!

Sure, here’s the customer id where adding another funding source is not working: eda16c8d-ab57-430a-94f4-392ff37962fc

Thanks for the ID!

The appropriate settings should now be reflected! Please let us know if you run into any further issues and we’d be happy to jump in!

Awesome, thanks for your help!

1 Like

I’m having this exact problem. The customerId I used is f4412e1c-71bd-4fe9-8684-6c9bea573aa2

Of course we need want to do be able to have 2 funding sources for other business verified customers we add. In previous sandboxes we were able to do that by using different account types (i.e one checking and one savings per customer)

1 Like

Greg’s problem is also affecting me, I’m writing code downstream of his blocker. Any updates on this? Thanks.

Hi @gfb107! I went ahead and updated your settings. Let me know if you run into any further issues.

Thanks for the fix. It looks like this problem is present when we create a new sandbox. Will that be fixed, so we don’t have to ask for intervention when we create a new sandbox?

1 Like

Yes, we have testing, staging, demo, production… the first three environment use sandboxes… we will need your help to get a fix for all of those? Or will you be fixing this issue permanently on your side for all newly created accounts? Thanks…

Here is the id of my currently broken sandbox in my development environment. Can you patch that one up for now?

37f42e16-45f7-4658-bc66-7abeee704779

However, as I mentioned, as devops, I have several more sandboxes to maintain, that are broken. Do I contact you for each one?

Thanks again.

Hi all!

The issue with the wrong account configuration affects Sandbox accounts created between Aug 1st 2020 and Dec 3rd 2020 (2020-08-01 to 2020-12-03). Any accounts created outside of the above timeframe aren’t affected. At this time, we have a ticket to go through the affected accounts and correct the settings.

In the meantime, an immediate and easier resolution to the problem would be to create a new Sandbox account and continue testing there. If you’d like to continue testing in your current/existing Sandbox account, let us know and we can individually update the correct account configuration!

We would like to apologize for the inconvenience. We hope to push out a fix for the affected Sandbox accounts soon!

Hi @Michael_Behrns-Mille!

It appears that the account associated with that Customer ID isn’t affected. You should be able to create up to 6 funding-sources for that Customer! Would you be able to share what errors you are seeing? If it isn’t related, we can move the conversation to a different post and resolve it there!

Let us know when you get a chance! :slight_smile:

I’m still having challenges with new dwolla sandboxes. Creating a second funding source for my only customer account is still giving me the “exceeded maximum” error. I only have one verified customer with one funding source. I need to create a second funding source. Do deactivated customers count against the total? I have two of those. I can’t delete them so I guess I’ll try yet another new sandbox…

Repeated the entire process with a new sandbox, it is NOT letting me create a second funding source. Here is the ID:

e1e24d95-5928-4a68-a920-dd775594f940

Can you see any kind of error log? Can you verify what is happening? I need to get this process working and repeatable. Thanks so much!

I retried creating a second funding account today, and it worked. Thanks.

Hello,

Hello,

We are using Dwolla’s me-to-me transfer API in our application. I tried adding my two checking accounts to our application. We also received the “MaxNumberofResources” error message. I only have one funding source connected.

Can you please assist?

Thanks!

Hi @Nishantdeshpande

Just got word that this was recently raised to two funding sources for you.

Yes, the issue has been resolved. Thank you!

1 Like