Bank of America Error: Multiple Clients

Greetings, Dwolla Community.

My company is new to the Dwolla platform. Our first three clients have attempted to enroll with Bank of America bank accounts. All three have received the same bad experience.

They select B of A from the list of banks, enter their correct login/password credentials, and the drop-in component does not let them proceed. They use the same credentials in a different browser tab and are able to successfully log in to the Bank of America website directly.

They the come back to our site and try again using the drop-in component, and the same failure occurs. On the third or fourth try, the Dwolla drop-in component no longer lets the client select B of A as a bank. It tells them they have to use a different funding source. Below is a screenshot of that error.

Can someone please advise as to what is happening? What kind of error is this? Is B of A blocking the Dwolla IP or something?

Any assistance is greatly appreciated.

Here is the error clients receive prior to the screenshot above. The screenshot above appears when the user clicks on Bank of America after receiving a couple of errors with this message:

Can someone from Dwolla provide information about what the errors from these two screenshots mean?

Thank you.


This error does not seem to be specific to Bank of America. Other customers are receiving the “please enter a different funding source” error when using banks like Suntrust.

Can anyone here assist please?


Hi @davidglines – sorry for the getting back to you late on this.

The timeframe for the Bank of America errors seems to be aligned with the the issues our third party bank verification provider was having with Bank of America during the following times.

Start Date End Date
2021-05-04 03:43:00 IST 2021-05-07 03:43:00 IST

The issue looks to have been fixed! Would you be able to give that bank another try and see if it goes through?

Looks like Suntrust bank was having technical issues as well during the following timeframes,

Start Date End Date
2021-05-02 00:00:00 IST 2021-05-04 00:00:00 IST
2021-05-08 20:04:00 IST 2021-05-10 20:04:00 IST

You should bee able to add those banks now! If you come across an issue with a bank again, let us know and we can check the status, or create a ticket on our provider’s site for a fix!

The customer who was having a problem with SunTrust just tried again, and she again received the same error. Please see attached issue. She swears the username/password is correct. At this point we have had 11 customers attempt to enroll, and 5 of them have received “try a different account” errors.
The banks are:

  • 2 B of A
  • 1 BB&T
  • 1 SunTrust
  • 1 Unknown

We will need to implement the backup micro-deposit process because of all of these online banking failures. This is a bit disappointing.

Is it just a coincidence that all of these banks are down between Friday and now?

Thank you in advance for taking a look.



Hi @davidglines – would you be able to share the Customer id for the user who is attempting to add their SunTrust bank again? The last issue with this bank was resolved by our provider on the End data noted above. As of yesterday, I am seeing a success rate of 33.33% for this bank on our provider Yodlee’s site. The rest was met with credential reverification errors.

Would you also be able to share the Customer Id for the BB&T bank attempt? I couldn’t find them on Yodlee’s site, perhaps due to their name change to Truist. After I have the Customer Id, I can take a deeper look into why this bank failed as well.

The backup of Microdeposits is highly recommended to ensure the ability for users to add + verify their bank accounts, because IAV isn’t guaranteed to support all banks. And unfortunately, like we’ve come across in this situation, there might be site failures with banks that impede the ability to run Instant Account Verification. Whenever these issue do occur, we at Dwolla can investigate if it’s a User error, or an error with Yodlee and the bank, and can help escalate the issue if it hasn’t been reported already!

It is a co-incidence that both B of A and SunTrust were going through fixes around the same timeframes. This isn’t expected to happen often. Again, if you do run into issue like these, please let us know and we can escalate it to Yodlee!

Shreya, here is the information you requested:

  • SunTrust Bank Customer: c2aeff6a-a8d8-415f-93f1-d91eae0f2f3e
  • BB&T Customer: d970b557-4ef6-441d-af98-58af58776478



Thanks DG! Thanks for those IDs.

I took a closer look into the logs for these Customers and found the following –

  • SunTrust Bank Customer: c2aeff6a-a8d8-415f-93f1-d91eae0f2f3e

It doesn’t look like this Customer is attempting to add a SunTrust bank. We’re seeing attempts to select “Security Bank of Kansas City” which is not supported by IAV. I have a create a ticket with Yodlee to enable this bank account for IAV. Meanwhile, the user would have to add it via microdeposits.

  • BB&T Customer: d970b557-4ef6-441d-af98-58af58776478

This Customer was rate limited due to entering the wrong login credentials. Entering the wrong login info twice will rate limit them for 30 minutes. This is to ensure that users aren’t able to attempt multiple times potentially getting them locked out of their online banking portal.

I’m sorry. I gave you an incorrect customer ID for the customer attempting to connect to SunTrust. Please see the corrected customer IDs below:

  • Security Bank of Kansas City: c2aeff6a-a8d8-415f-93f1-d91eae0f2f3e
  • SunTrust: fc604f01-ad58-4c7b-8037-0cc528a3d5de

The customer who is attempting to connect to SunTrust says that when they click SunTrust, it takes them to a completely different bank.

I’ve informed the Security Bank of KC customer that they will need to use micro deposits.


No worries! I am seeing a series of login failures and rate-limiting for that Customer. Probably because they’re using their login credentials for a different type of SunTrust Bank.

The login URL of the bank account that IAV supports is as follows - SunTrust Online Banking

Perhaps the User has a different login for their SunTrust bank, which isn’t supported.